What Browsers Does Sprout Social Support?

Sprout is tested with the web browsers listed below. You may be able to log in with older versions, but newer features may not look or work as intended. It is recommended that you always use the most current version of a browser and select the option for automatic updates.

Note: A browser that supports TSL 1.1 is required to access Sprout. The latest versions of each browser support this feature. If you notice you cannot access Sprout Social, please try updating your browser.

Focusing on these versions allows Sprout to develop and test new features more quickly, allowing for increased speed, security and a better user experience. Some new features rely on technology that is only supported by more modern web browsers.

The term “latest version” is defined by each browser. Use the links below to understand which version you are using. 

Chrome

Sprout supports the latest version and previous version

Find out which version of Chrome you're using

Safari

Sprout supports the latest version and two previous versions

Find out which version of Safari you're using

Firefox

Sprout supports the latest version and previous version

Find out which version of Firefox you're using

Internet Explorer

Sprout supports the latest version

Find out which version of Internet Explorer you're using

Mobile

Sprout can also be accessed from mobile devices but is not supported for mobile browsers. For the best mobile user experience we highly recommend using the latest version of the Sprout Social app (available for iOS and Android).

Was this article helpful?

Still can't find what you're looking for?

Powered by Zendesk